Adding the landingpage to your own custom domain is now possible! 

Important: it requires access to your website's DNS settings to make it work.


So let's say you are the proud owner of the following domain: www.bestbotintown.com and would like to have a nice Quriobot accessible via example.bestbotintown.com. These are the steps you need take to make that possible.


Step 1: Add the domain you want your bot to be available from on the Domains tab on the Organization Settings page, and click New.

Before you can add a new domain you need to add two records (a TXT and a CNAME record) to the DNS settings of the domain you want to connect it to. This has to be configured via the interface of your hosting provider.

Important note: The main domain name is also added in this example as well, but please be aware that, unfortunately, not all DNS tools will automatically strip that from your DNS record as officically it should only be the name of your subdomain (which is example in the exmaple above).



Another important note: Only after you have added these records to the DNS can you successfully add the domain. This is to proof you have the right ownership of that domain and is needed for the DNS so it knows where to find the requested page.

Note: Although each hosting provider will have different interface it will most likely consist of the following three elements: 1. The record name (on the left) 2. the record type and 3. the Record value (on the right)


After you have added a TXT record and a CNAME record to your DNS, you can add the custom domain to your account.

Note:  Please keep in mind that it can take some time between adding the DNS records and clicking save, as it can take a little while for those DNS settings are 'known' everywhere,

  

Step 2: Create a bot (but I am guessing you already did that)

Step 3: Select the domain from the drop-down you want to connect it to on the Landing page tab

That's it, the bot is now accessible via your customdomain.domain.com!



I cannot verify my custom domain and my DNS provider is CloudFlare

The reason for this is most likely that you have CNAME flattering setting enabled. You'd need to disable it in order to verify the domain:


https://support.cloudflare.com/hc/en-us/articles/200169056-Understand-and-configure-CNAME-Flattening


How about SSL?


Currently Quriobot doesn't provide SSL certificates for your custom domains nor it currently allows to use your existing certificates.

But there's a working solution to this! By using Cloudflare's flexible SSL service you can communicate the https address to your clients and then Cloudflare service will connect to Quriobot using plain HTTP.



please check out:

https://support.cloudflare.com/hc/en-us/articles/204144518-SSL-FAQ



Need more help or looking for inspiration? Join the Quriobot community!

Quriobot
Friendly & Fun
Interact & Convert